Thread Closed

#1
Hi,

I'm running Debian Squeeze 32 bits with GNOME and firefox 3.6.16 and thundrbird 3.1.9.

The minimizetotray-plus-1.0.9.xpi returns the "cannot find binary component" error (the minimizetotray-plus-1.0.8.xpi returns the same error).

I search the forum for a solution but without any result.

What should I do to fix it ?

Thank you in advance.

Edited by john on April 4, 2011, 1:52 a.m.

ReportQuote
#2
I don't know, it should just work. I compiled the binary on Ubuntu so our systems should be close.

You you paste this into the Error Console and then press Evaluate and then put the response here.
Components.classes["@mozilla.org/xre/app-info;1"].getService(Components.interfaces.nsIXULRuntime).XPCOMABI

Have I helped you? Do you like my add-ons?
Would you consider donating to show your appreciation for my efforts?

/images/paypal.png
ReportQuote
#3
Hi Michael,

Thank your for reply !

Well, I copy/paste your code in the error console (of thunderbird) and here is the response :

x86-gcc3

One more thing if it can help, in the message error, I have the following messages too :

Failed to load XPCOM component: /media/PROFILES/Thunderbird/extensions/{de1b245c-de57-11da-ba2d-0050c2490048}/library/Linux-32/MinimizeToTrayPlus.so

And this one (I don't know if it is minimize to tray related) :

2011-04-04 14:16:57	gloda.index_msg	ERROR	Problem entering folder: ccm, skipping. Error was: undefined:651: [Exception... "Component returned failure code: 0x80550006 [nsIMsgFolder.msgDatabase]"  nsresult: "0x80550006 (<unknown>)"  location: "JS frame :: file:///opt/thunderbird/modules/gloda/index_msg.js :: gloda_index_indexerEnterFolder :: line 651"  data: no]

Once again, thank you for your help, minimize to tray is just necessary for me ;)
ReportQuote
#4
Can you try coping the file
/media/PROFILES/Thunderbird/extensions/{de1b245c-de57-11da-ba2d-0050c2490048}/library/Linux-32/MinimizeToTrayPlus.so to /media/PROFILES/Thunderbird/extensions/{de1b245c-de57-11da-ba2d-0050c2490048}/components/MinimizeToTrayPlus.so and deleting the loader.js from the same folder?

Have I helped you? Do you like my add-ons?
Would you consider donating to show your appreciation for my efforts?

/images/paypal.png
ReportQuote
#5
Hi michael,

I follow your instruction, but still have the "cannot find binary component error".

Here is the error message I have in the error console :

uncaught exception: 2147746065

Failed to load XPCOM component: /media/PROFILES/Thunderbird/extensions/{de1b245c-de57-11da-ba2d-0050c2490048}/library/Linux-32/MinimizeToTrayPlus.so

Once again, thank your for your help, I'd really like to have minimize to tray working.

Edited by john on April 6, 2011, 4:39 a.m.

ReportQuote
#6
There must be some reason that the supplied binary does not work on you computer. Maybe a different set of libraries or something like that. At this stage that is all that I can think of, and I am not sure what to actually to do for fixing that, besides recompiling on your own computer. Which is a pita to to.

Have I helped you? Do you like my add-ons?
Would you consider donating to show your appreciation for my efforts?

/images/paypal.png
ReportQuote

Thread Closed