Thread Closed

#1
I add the turbo mode to startup in GNOME, Debian Linux. When I close the Firefox window or all its tabs, log out and log in, and then open a Firefox window, the last open tabs show up again.

A more desirable behavior would be that tabs wouldn't reappear when they (or the Firefox window) were all closed in the last session.

However, thanks for this great add-on. Its turbo mode is unique as far as I know.
ReportQuote
#2
What are your settings for "When Firefox Starts" it should be following what it says?

Yes all the similar extensions don't have turbo mode, and I don't think the developers are interested in adding it - I am in contact with some of them. Well some of the other Windows only versions have a partly working solution...

Have I helped you? Do you like my add-ons?
Would you consider donating to show your appreciation for my efforts?

/images/paypal.png
ReportQuote
#3
I always choose "Show a blank page" with the option "When Firefox starts".

I think that this behavior is related to Session Manager because if I clear 'closed' list with it before log-out, Firefox will start with a blank page after log-in.

Thanks for your reply in any case!
ReportQuote
#4
I will investigate further then.

Have I helped you? Do you like my add-ons?
Would you consider donating to show your appreciation for my efforts?

/images/paypal.png
ReportQuote
#5
It seems that Firefox insists on restoring the last session unless it's quit completely. With the turbo mode, Firefox isn't quit before log-out, so it restores the last session after log-in, as if it's restarted. I tried many settings in about:config to no avail :(
Fortunately, there's the workaround I mentioned above.
ReportQuote
#6
If you have fast user switching enabled (or what ever it is called) it might not be stopping the Firefox process, but just leaving it running. In which case, yes this will happen.

Have I helped you? Do you like my add-ons?
Would you consider donating to show your appreciation for my efforts?

/images/paypal.png
ReportQuote
#7
It's not related to fast user switching. Now I'm sure it's not caused by MinimizeToTray Plus either. It seems to be a persistent behavior of FF >= 3.*. The way to reproduce without this add-on:

(1) Disable session restoring via about:config;
(1) open some web pages in some tabs;
(2) log out without closing tabs or FF;
(3) log in and open FF.

Then you'll see the previous session restored. This isn't a crash recovery; no crash has happened.

The best workaround I've found until now is to automatically remove 'sessionstore.js' from the FF profile directory before log-out by adding the following line to /etc/gdm/PostSession/Default (for GNOME):

rm /home/<USER>/.mozilla/firefox/<profile>/sessionstore.js
ReportQuote
#8
But maybe because it is sending the kill signal to Firefox it seems to be a crash like event to Firefox.

Following those steps I get the same result as you do.

Have I helped you? Do you like my add-ons?
Would you consider donating to show your appreciation for my efforts?

/images/paypal.png
ReportQuote
#9
Thanks for your confirmation.

IMHO, if it was treated as a crash, the crash dialog should show up. In addition, it also happens when the crash recovery is disabled.

All in all, I'm satisfied with my last workaround :) (I don't know if something similar could be done in Windows too.)
ReportQuote

Thread Closed