Thread Closed

#1
I have a slightly strange problem.
Up until know I've been using the utterly outdated "minimize2tray" version. I had "Minimize when pressing close button " activated and it did just that. When i pressed ctrl+w tho the window would be closed and not minimized, which is just what i wanted.

Now I've started to use your new "MinimizeToTray Plus" and i can't seem to close (empty) Browser Windows anymore when activating "minimize on close". When i try to close it via or ctrl+w it just minimizes and when i close Firefox via File->Exit and then restart the empty Window comes back. The only way to close the window was to disable "minimize on close". I think it might be caused by my firefox setting "do not close window with last tab".

So it would be nice if you could implement some sort of shortcut to close windows even with "minimize on close" enabled. (Sometimes i do want to have several windows minimized, so using only one is not an option for me. Additionally i press all the time to minimize because it's easier to navigate compared to ^_^)

Thx and have a nice day ;)
ReportQuote
#2
Yes pressing ctrl+w does cause the window to be minimized if that option is set. That was introduced in 1.0.3 I think. But I take your point, and I will see what I can come up with for the next release.

Have I helped you? Do you like my add-ons?
Would you consider donating to show your appreciation for my efforts?

/images/paypal.png
ReportQuote
#3
That would indeed be great!

Adding a setting toggle the behavior of ctrl+shift+w or a customizable keyboard shortcut (or maybe alt+shift+w?) would just do the trick i guess.

For now I've disabled "minimize on close" and already killed the window a dozen times instead of minimizing it :p. Btw, i meant "ctrl+shift+w" and not "ctrl+w" of course, but i guess you already noticed that.

(On a side note after reading the feature request topic item 9 I wanted to tell you that I'm using XP x64 and it works just fine :D.)
ReportQuote
#4
Yes I noticed the change in shortcuts. What I think I might do is just add a hidden preference to control this behavior. If you feel like hacking the extension, your could turn this off by deleting the last if statement and all its contents from the /chrome/minimize.jar/content/core.js file.

Your running a 32bit version of Firefox. There are some third party builds of Firefox around that are 64bit instead of the Mozilla ones with are all 32bit. They are supposed to be 10%-20% faster - which would be the only reason you might want to use them - the reason few people would ,given they even if they knew about them, is that many plugins (like Flash) don't work.

Have I helped you? Do you like my add-ons?
Would you consider donating to show your appreciation for my efforts?

/images/paypal.png
ReportQuote
#5
I'm amazed how you manage to answer withing half an hour regardless of the time i post, regrettably I'm not quite that fast myself ;D.

With hidden preference i guess you mean something in about:config? That would do the job i guess. I tried deleting the if statement in core.js (the one after "// override this function so it does not close the window if") but i still couldn't close empty windows with either c+s+w or when "minimize on close was enabled".

True, I'm using 32bit fox, wasn't thinking about that. I'm too dependent on my addons tho (flash wouldn't bother me...), so switching isn't an option :|.

(On yet another side-note: I'm also running chatzilla on an independent xulrunner and mmt+ sadly doesn't work for that one... Maybe, just maybe you could make that possible too ^_^)

Haste makes waste, so have a nice day ;)
ReportQuote
#6
If I am on the computer (which means all day right now since I am on holidays - but only for one week more) do I reply quickly.

That is strange as that is the code that overrides the normal crtl+w action. You might have made some error, which is quite easy to do.

I do plan to support as many applications like Chatzilla as I can. Just a matter of time before I get around to them all.

Have I helped you? Do you like my add-ons?
Would you consider donating to show your appreciation for my efforts?

/images/paypal.png
ReportQuote
#7
Hey again,

After reading your answer i just had to try again and now it works like i always loved it ;). Turns out that not me but you made a mistake (either in describing the procedure or somewhere else?) :p. The relevant if-block has to be removed in both core.js and browser.js for ctrl-shift-w to work again.

Wish you a nice holiday ;)
ReportQuote
#8
Mea cupla. I forgot about that one.

Have I helped you? Do you like my add-ons?
Would you consider donating to show your appreciation for my efforts?

/images/paypal.png
ReportQuote

Thread Closed