Post new Reply

#1
No longer seems to work with Firefox 37 (Beta, Build 20150312193711, but possibly earlier) for linux. I loved this button. If it's not just my particular set of extensions causing the problem, being able to have it sticky for individual pages would be a nice additional touch...

Thanks,
Bev
ReportQuote
#2
Hi, I have fixed this. They changed how page colours works in Firefox 37. If you want the working version now you can use one of the following:

https://codefisher.org/toolbar_button/nightly/
https://codefisher.org/toolbar_button/toolbar_button_maker/

Have I helped you? Do you like my add-ons?
Would you consider donating to show your appreciation for my efforts?

/images/paypal.png
ReportQuote
#3
Thanks, but this didn't work either. Do some buttons NOT work with some extensions?
ReportQuote
#4
All buttons should work all the time.
Is it possible that you did not disabled/remove Toolbar Buttons 1.0.2 before trying them?

Have I helped you? Do you like my add-ons?
Would you consider donating to show your appreciation for my efforts?

/images/paypal.png
ReportQuote
#5
The 'nightly' wrote over the 'regular' version. I just deleted TB and restarted FF a couple of times before downloading and installing the 1.0.4 nightly and restarting. Still no joy, but 'Page Fonts' works nicely.

I mostly want it for changing the color of 'read' links at sites that don't do it automatically -- The AP newsfeed (1 line per headline) is mostly what I want so I'll EASILY see where I left off.

I suspect that there's some extension or entry in user*.css that's sabotaging your work, and that's not your problem. I'll try installing the Thunderbird version and see what happens...
ReportQuote
#6
It works fine in Thunderbird, so I conclude it's my fault. Thanks anyway, the other buttons are fine!
ReportQuote
#7
I doubt it is your fault. They might have changed something again since I tested it on the Firefox 37 alpha, and the beta you are using. I will have to download the beta tomorrow and check it out.

Have I helped you? Do you like my add-ons?
Would you consider donating to show your appreciation for my efforts?

/images/paypal.png
ReportQuote
#8
In case a fix hasn't been found yet...

The Page Colours custom button works for me if I change a line in button.js
from:
toolbar_buttons.prefToggleNumber(button, "browser.display.use_document_colors",  [2, 2, 0]);
to:
toolbar_buttons.prefToggleNumber(button, "browser.display.document_color_use",  [2, 2, 0]);


Testing was on Firefox 37.0. I tested Toolbar Buttons Nightly 1.0.4b1.r201 and a Custom Button created on 2015-04-02.

Unrelated: The Restart button is named "Toolbar Buttons" in the Add-ons Manager.

Forum login attempts are resulting in "Internal Server Error".
ReportQuote
#9
Hi,
I forgot to go back and look at this, but yeah, your change is rather obvious if I had stopped to look at it. I will do it right now.

I had a look for a possible cause of the button being named wrong. I found some other bugs in button maker caused by recent updates in the backend, but I can't see this happening and I can't reproduce it right now.

The login problem is because a lot of the passwords are corrupted. I causes the login system to simply refuse to do anything. I am going to try and clear the corrupted passwords out when I get time, but if you want to log in again, your going to have to reset your password. Sorry about that.

Have I helped you? Do you like my add-ons?
Would you consider donating to show your appreciation for my efforts?

/images/paypal.png

Edited by Michael on April 3, 2015, 8:29 a.m.

ReportQuote
#10
I found my mistake with the Restart button: Two buttons were selected instead of just the one I intended to make.

The custom Page Colours button does work again. I think it will be popular this week.
ReportQuote
#11
I don't seem to have a button.js file. Just these:
bb:/root>locate button.js
/stuff/avidemux/avidemux_2.5.6/autononreg/dialogFactory/button.js
/stuff/qt-everywhere-opensource-src-4.7.1/src/3rdparty/webkit/WebCore/inspector/front-end/StatusBarButton.js
/root/.mozilla/firefox/8i2k59bx.30Test/extensions/https-everywhere@eff.org/chrome/content/toolbar_button.js
/root/.mozilla/firefox/8i2k59bx.30Test/extensions/{3e0e7d2a-070f-4a47-b019-91fe5385ba79}/chrome/content/MainButton
/root/.mozilla/firefox/8i2k59bx.30Test/extensions/{bee6eb20-01e0-ebd1-da83-080329fb9a3a}/modules/ToolbarButton.js
/root/.mozilla/firefox/08cgmz2x.18/extensions/https-everywhere@eff.org/chrome/content/toolbar_button.js
/usr/share/apps/plasma/dashboard/button/genericButton.js
/usr/share/apps/plasma/dashboard/AppleClasses/AppleInfoButton.js
/usr/share/apps/plasma/dashboard/AppleClasses/AppleButton.js

and
bb:/root/.mozilla/firefox/8i2k59bx.30Test/extensions>grep buttons.prefToggle *
bb:/root/.mozilla/firefox/8i2k59bx.30Test/extensions>

<crickets>
ReportQuote
#12
You would have to unzip the .xpi file to find it. No need to do so, just download the extension again.

Have I helped you? Do you like my add-ons?
Would you consider donating to show your appreciation for my efforts?

/images/paypal.png
ReportQuote
#13
Downloaded the nightly and installed from the .xpi. No joy. At this point I'm SURE that it's some other extension or entry in one of the .css or .js files causing the problem and nothing that's your problem. It works fine with Thunderbird. Next time I have a SERIOUS problem I'll go through the disable-half-and-restart process and report back.
ReportQuote
#14
For some reason the nightly hasn't been updated since March 13. The custom button maker works.
ReportQuote
#15
There is a typo in the cron task for building the nightly. Just fixed that now, and manually ran the script as well.

Have I helped you? Do you like my add-ons?
Would you consider donating to show your appreciation for my efforts?

/images/paypal.png
ReportQuote
#16
YESSSSSS! Finally!
ReportQuote
#17
...and then I updated Firefox to 38 beta and all hell broke loose -- I couldn't change any of my preferences, although I could get to the preferences page, and more than half the buttons disappeared. Changed back to the release rather than beta mode, downloaded 37 again and copied over my old profile to the new profile and everything is lovely again. Just thought you should know.
ReportQuote
#18
Thanks for the heads up, I don't tend to run beta's much, don't like to deal with the problems. But I will check this out.

Have I helped you? Do you like my add-ons?
Would you consider donating to show your appreciation for my efforts?

/images/paypal.png
ReportQuote
#19
I figured it was maybe a duty to occasionally run betas and complain loudly about the problems -- this is the first one I've had in maybe a year and it's a doozy! I would think it would be a real nuisance for developers to try to keep updating extensions whenever a new beta comes out; Firefox seems to issue one every few days.
ReportQuote
#20
If you do that it is a great help to developers, and it keeps those bugs out of the stable releases.

I just downloaded the Firefox Beta, but don't see any of the problems that you described. So I don't know what is going on. I will keep an eye on it though.

Have I helped you? Do you like my add-ons?
Would you consider donating to show your appreciation for my efforts?

/images/paypal.png
ReportQuote

Post new Reply