Post new Reply

#1
I have Pale Moon 25.2.1 (based on Firefox) installed on a Win 7 Pro (64 bit) computer.

If I install the Firefox version of Toolbar Buttons 1.0.2, everything works just as it should. All (I assume it is all, since I did not count them) appear on the Customize Toolbar screen.

But I don't need all these buttons. So I Removed Toolbar Buttons 1.0.2, and restarted Pale Moon. I then tried to install the few I needed separately from the Toolbar Button List. Each time I tried to install one, I got a Pale Moon error message which said the button was not compatible with Pale Moon 25.2.1, although each I chose was in Toolbar Buttons 1.0.2. I also tried the Custom Install method where I could select a group that I wanted installed. Same error message.

Any idea what the problem might be? Or if that can't be solved, is there any way that I can remove all the buttons I don't need from the the complete set that was downloaded?

Thanks,


Harry
ReportQuote
#2
Hi Harry,

For the next version of Toolbar Buttons (which the custom button maker is already using) I bumped the min version of Firefox up to 29 (since that is what I have tested against). Since Pale Moon lists its version as 25, that causes problems.
The solution is simple, add a Paul Moon to the compatibility list so it does not fall back to using the Firefox one, I will check that change in soon hopefully.

The other thing is Pale Moon does not support "Australis", see https://addons.palemoon.org/resources/incompatible/
I do use it, but I have a fall back. I don't know how stable it is, so if you end up having problem with future versions of Toolbar Buttons, I would appreciate if you report problems quickly. This also effects SeaMonkey.

Have I helped you? Do you like my add-ons?
Would you consider donating to show your appreciation for my efforts?

/images/paypal.png
ReportQuote
#3
QUOTE: *
Hi Harry,

The solution is simple, add a Paul Moon to the compatibility list so it does not fall back to using the Firefox one, I will check that change in soon hopefully.

The other thing is Pale Moon does not support "Australis", see https://addons.palemoon.org/resources/incompatible/
I do use it, but I have a fall back. I don't know how stable it is, so if you end up having problem with future versions of Toolbar Buttons, I would appreciate if you report problems quickly. This also effects SeaMonkey.



Thanks for the comprehensive reply. Just reply to this thread whenever you add Pale Moon (Ver. 25.x) to the compatibility list.

Pale Moon does not aupport 'Australis', as you indicated, and according to the program author, never will.

I also have Firefox 36 installed on the same computer, so I tried Custom buttons on it. Was able to load Custom buttons, and they seem to work fine. Three items which you may already know:

1. After I click Download on Custom Buttons, I always get this message from Firefox: "Firefox prevented this site (codefisher.org) from asking you to install software on your computer." I click the 'Allow' button, and then it is installed.

2. The alphabetical list on Custom Buttons https://codefisher.org/toolbar_button/toolbar_button_maker/
ends with 'Themes'. I had to go to Toolbar Button List->Show Details to add 'Top' and 'Undo Close Tab'.

3. On the Settings options below the list of Custom Buttons, unchecking 'Automatically add buttons to main toolbar' works fine. However, checking 'Create a menu of selected buttons' does not seem to work at all. There is no selected buttons menu placed in my Firefox Tools menu.

Harry
ReportQuote
#4
Ok, it should install into Pale Moon now. As said before you will be using the fall back code, since it lacks Australis. Let me know if you have problems.

As to your three items.

1. Firefox will always do it unless you go to the options window, and under security add my site as an exception. I don't recommend it, though unlikely, it is always possible that my site could get hacked or something.

2. Did not know that. Turns out the list filter plugin has pagination, which I did not know about, and had not set up. Decided I actually really like the feature, so I have set it up properly.

3. Are you sure? It should add a menu called "Toolbar Buttons" into the Tools menu.

Have I helped you? Do you like my add-ons?
Would you consider donating to show your appreciation for my efforts?

/images/paypal.png
ReportQuote
#5
Michael:

I downloaded 6 items to Pale Moon 25.2.1. They downloaded just fine, and so far they all function correctly.

I'm not sure how the list filter pagination is supposed to work, but you can only download items on one page at a time. For example, I first selected items on page 1, and then more on page 6, and then clicked Download. Only the items on page 6 were downloaded/installed. So I then had to go back to page 1, select those, and download again.

Sorry, but no menu called "Toolbar Buttons" has been added into the Tools menu, either in Firefox 36 or Pale Moon 25.2.1. I was going to attached a screen shot of my Pale Moon Tools Menu, but I can't figure out how to add an attachment to this post.

Harry
ReportQuote
#6
Ok, good to know Pale Moon is working :)

Yeah I noticed the problem about the pages this morning, and turned it off again. I did like it though.

Ok, I will have to check that menu out in more detail. Hopefully it is just a simple config error somewhere, because it is working with the version I am running on my computer.

Have I helped you? Do you like my add-ons?
Would you consider donating to show your appreciation for my efforts?

/images/paypal.png
ReportQuote
#7
Attachments have not yet been implemented on this forum. I will get around to that sometime - for better or for worse I decided to write my own forum software...

I found the problem with the menu not appearing, and that is resolved now.

Have I helped you? Do you like my add-ons?
Would you consider donating to show your appreciation for my efforts?

/images/paypal.png
ReportQuote
#8
Michael:

>>Yeah I noticed the problem about the pages this morning, and turned it off again. I did like it though.

Works great now, even if you don't like the one long list.

>>I found the problem with the menu not appearing, and that is resolved now.

Yes, it works now for me also.

>>for better or for worse I decided to write my own forum software...

You are a glutton for punishment!

Thanks for all your help on this. I tried a lot of the options, but I finally settled on just three.

I think I am all set now.

Harry
ReportQuote
#9
Michael:

I found a few glitches that you may or may not know about.

1. I had previously gone to Custom Button Sets, and downloaded three buttons, ONLY checking the "create a Menu of selected buttons' option. Worked fine. Today I went back to Custom Button Sets, selected two more, and repeated the procedure. The two new buttons did NOT appear on the Menu of selected buttons--only the original three did. I had to Remove both of these add-ons from Pale Moon, and repeat the process, this time selected all 5 buttons for one download. Now they all appear on the Tool Bar. If this is how it is supposed to work, there should be a note to that effect.

2. One of the buttons I downloaded was 'Run Application'. Although I can add more than one to the List on the Edit Applications screen, only the last one added appears on the Run Application drop down menu. Also, the Edit feature does not seem to work. I had to delete the entry from the list, and then reenter it.

Harry
ReportQuote
#10
Hi Harry,

1) is certainly a bug, that is not how I want it to be. I will check that out soon. I was planing to rework a lot of the menu code sometime this week, so I will keep this is mind when I do.
2) I did not know there is problems with the Run Application button. I fix that hopefully soon.

Thanks for the reports, they help a lot in trying to maintain the extension.

Have I helped you? Do you like my add-ons?
Would you consider donating to show your appreciation for my efforts?

/images/paypal.png
ReportQuote
#11
Michael:

Thanks for taking a look at these issues.

Just put a post here when you get your currently planned updates done, so I can check them.


Harry
ReportQuote
#12
Mostly finished reworking the menu code now, I changed from using regex to a xml parser to generate it and that has simplified it a lot, while allowing me to add extra features. I don't see the problem you reported after the changes. Just a few things to check before I roll it out. Will post when I do.
With the other problem, I have not looked at it yet, but I found out that one of the data storage APIs don't work as I thought, and that I guess is likely the problem.

Have I helped you? Do you like my add-ons?
Would you consider donating to show your appreciation for my efforts?

/images/paypal.png

Edited by Michael on April 2, 2015, 5:21 a.m.

ReportQuote
#13
I squashed so many bugs today it is awesome :) And I just rolled out what I have been working on. Both bugs should be fixed, let me know if you have any issues.

Have I helped you? Do you like my add-ons?
Would you consider donating to show your appreciation for my efforts?

/images/paypal.png
ReportQuote
#14
Michael:

The good news:
1. Run Application works just as it is supposed to. A wonderful button.
2. I can load several buttons at one time, and then load others later, and they all appear in the Tools menu.

The maybe not good news:
1. If I load several button initially, they all appear in the Tools->ToolBar Buttons menu, as you said they should. But when I add additional buttons (I only loaded one each time), they appear directly in the Tools menu, not in the Tools->Toolbar Buttons menu. They also appear as separate items in the Tools->Add-ons list. Is that how you have designed it?


Harry
ReportQuote
#15
Good to know that those problems are solved for you too now :)

With the other point, I figured it a good idea to do it like that. If someone installed only one extension, with only one button, it does not make sense to put it into a submenu.
It is however only a configuration option. I have this idea that sometime I will create a version of the custom button maker that exposes more of the options that can be passed to the build script. Currently there are about 70 config options that can be changed, of which only some are exposed via the web form.

Have I helped you? Do you like my add-ons?
Would you consider donating to show your appreciation for my efforts?

/images/paypal.png
ReportQuote
#16
Michael:

I understand your logic for leaving these single entries in Tools.

Another small problem. I have an earlier version of Firefox installed on an XP computer. The new Custom Buttons will not install on it, but the Toolbar Buttons 1.02 did. However, the 'Run Application' icon is nowhere to be seen in the 'Customize...' section, nor does it appear to be installed anywhere else. It was listed as one of the buttons. Does this not work, or did I miss something?

Harry
ReportQuote
#17
I have bumped the min version up quite high for the newer versions, since I started using Australis with needs at least Firefox 29. I guess I could drop it down again, now that the fallback code (written for Thunderbird/SeaMonkey/Pale Moon) is fully working. But it still depends how early the version is, I can't drop it much below 20.

Run Application was created after the release of 1.0.2, and I doubt I will put it in for another few releases.

Have I helped you? Do you like my add-ons?
Would you consider donating to show your appreciation for my efforts?

/images/paypal.png
ReportQuote
#18
QUOTE: *
I have bumped the min version up quite high for the newer versions, since I started using Australis with needs at least Firefox 29. I guess I could drop it down again, now that the fallback code (written for Thunderbird/SeaMonkey/Pale Moon) is fully working. But it still depends how early the version is, I can't drop it much below 20.

That is a business decision on your part. I have Firefox 20.0.1 and Pale Moon 24.7.2 (~ same as Firefox 24) on my XP computer, but I don't use it much anymore, and fewer folks do. I was just going to do some testing, that was all. So please do NOT change this on my part, since it is all working so well now.

QUOTE:
Run Application was created after the release of 1.0.2, and I doubt I will put it in for another few releases.

I guess that is why I could not find it.

Thanks for all your help and customization.

Harry
ReportQuote

Post new Reply