Post new Reply

#1
It has stopped working with the 33.1.1 FF update of 17th November 2014.

Obviously incompatible with another extension (perhaps Classic Theme Restorer or File and Folder shortcuts).
ReportQuote
#2
What exactly stopped working? In what way does it not work? Do certain buttons not work, or do they not display at all? Or has it stopped installing correctly for you?

For me it works, so unless I find out the difference between your set up and mine there is no way to fix it. If it might be one of the other extension, can you disable them and see? I can then download the code and see what I can do to fix the incompatibility.

Have I helped you? Do you like my add-ons?
Would you consider donating to show your appreciation for my efforts?

/images/paypal.png
ReportQuote
#3
I can confirm that Toolbar Buttons quit working with FF 33.1.1.

I disabled all extensions except Toolbar Buttons 1.0.1, and FF 33.1.1 will not start. There are no error messages, but Firefox is left running as a zombie process.

I've checked with some friends that have dissimilar PCs. However, each machine did have Toolbar Buttons installed. None had updated Firefox to 33.1.1 yet, so they had not seen any problems. As soon as they updated FF and got the latest version of Toolbar Buttons installed, one by one they called back and said that FF would not start.

Let me know if I can provide any more info.
ReportQuote
#4
I will look into this soon. But it sounds bizarre that my extension would cause this to happen.

Have I helped you? Do you like my add-ons?
Would you consider donating to show your appreciation for my efforts?

/images/paypal.png
ReportQuote
#5
With the latest update, the button "toggle colors" became invisible on my toolbar. A placeholder appears on mouseover, but I cannot tell if colors are on or off any more, and I cannot even see where the icon is, unless I mouseover it.

How can I go back to the last version?
ReportQuote
#6
Here's a screenshot of my problem:
https://dl.dropboxusercontent.com/u/3990811/togle-colors.png
ReportQuote
#7
I have noticed that with Toolbar Buttons 1.0.1 and FF 33.1.1 the Bookmarks Toolbar button has lost its icon and is blank. Also, FF freezes completely when the Toggle Toolbar button is moved from the Customize window to the Nav Toolbar.

I have had to revert to Toolbar Buttons 1.0 to get the icon back on the Bookmarks Toolbar button.

FYI, I am also using Classic Toolbar Buttons and Classic Theme Restorer on a Win7 system.

Edited by ed1 on Nov. 17, 2014, 11:21 p.m.

ReportQuote
#8
More about my problem. FF 31.1.1 on Win 7 Ultimate.

In common with other posters, I had a FF hang after the update, and my TB customised buttons disappeared from the toolbar and sidebar containing them; leaving only the dividers on the toolbar. The buttons had been added a long time ago by dragging to bars in the Customise setup.

I have tried various combinations of enabled and disabled addons, but cannot get FF to work with the TB buttons or without hanging (possibly unresponsive script in chrome, but I can't be sure).

I have used the TB toolbar builder to build a dedicated TB bar with a selection of buttons which previously worked in a non-dedicated toolbar, along with other buttons from other addons. This TB bar works OK, although I have had problems with a previously separate toolbar now appearing on the end of the TB toolbar.

In order to investigate this further, I will need to copy my current profile, then amend it as necessary to reinstall TB as a regular addon rather than toolbar. Thereafter, it will be a question of binary disable/enable of all addons to check, which will take some time. However, if the problem is in the new FF rather than addon interaction, that won't help.

I notice that there was a crop of updates to other addons yesterday, and have tried to investigate these, as being more recent, they may be the cause. Nothing has so far shown up.

I also have another Win 7 machine which I can use to investigate this.
ReportQuote
#9
What happened to me in Firefox 33 was that some custom toolbar buttons that I made a long time ago using the custom buttom maker,stopped working after this latest update-they were automatically disabled and marked as incompatible.
The solution has been just reinstalling the older buttons over the last update,and they still work.
ReportQuote
#10
I've also tried in a clean profile,where the only installed addons were these very same buttons:they worked,then immediately after checking for updates have been disabled because incompatible.
ReportQuote
#11
I have very few extensions, the toggle Bookmark Toolbar button worked fine in FF 33.1 until the toolbar buttons update when the toggle Bookmark Toolbar button went blank.
When I went looking for the button and added it back to my toolbar it now gives a drop down list rather than toggling the Bookmark Toolbar.
This probably my most used toolbar button - please bring it back.
ReportQuote
#12
Success of a sort.

I have:-
1) copied my existing profile with Toolbar Buttons as a toolbar and Classic Theme, plus all other addons, to a new profile folder.
2) started FF up with new profile, then disabled Classic Theme and removed the TB toolbar.
3) restarted FF and re-enabled Classic, and installed TB 1.0.1.
4) checked that I can drag TB buttons from Customise to toolbars, and this works OK.
5) a number of addons required updates, so these were downloaded. This then re-enabled (among other things), a Files and Folders Addon toolbar, and Googlebar Lite as a separate bar.
6) restarted and changed the themes a few times.
7) dragged the various extra TB buttons that I use (mainly those for bookmarks and tab management) to various tabs.

I now have a profile which is pretty much the same as that which I had and which was working prior to the 33.1.1 update. So I'm happy with that (as long as it all keeps working).

However, there is no clear indication of what may have caused this problem in the first place, and no one addon suggests that it was the one that broke it.
ReportQuote
#13
UPDATE:
The Toggle Bookmark Toolbar has no icon - it is blank. When I drag the blank icon to the toolbar it remains blank, but DOES toggle the Bookmark Toolbar.
The problem is that the toolbar is also blank. The list shows and works from the Bookmarks drop-down, but the Bookmark Toolbar remains blank no matter HOW it is opened - be it the Toolbar Buttons button or from the View-Tool Bars-Bookmark Toolbar in FF.
ReportQuote
#14
Ok, for those that want a quick solution, you could try going back to the previous release which can be download from https://codefisher.org/download/toolbar_buttons/toolbar-buttons-1.0.xpi

@ozarks, ed1, Powhyfo
About the icons. Sorry about this. The problem is a bug in the script that is supposed to pack all the icons into one image was creating what seems to be a partly corrupt image. 11 lines of code later it is all good again. So as soon as I get the next release out this will be solved.

@Foxfan100
Thanks for all the feedback. Nice to see you got something working, but I would want to get further then that. I don't know what is causing this, as I can recreate the problem. I do have a few thoughts though, so if you still have the problematic profile around, we can test this out. What I can think of now is that it could be.

1. Something do with the corrupt icons. It is possible, but I doubt it.
2. I noticed that the script that is supposed to run when the extension is first installed is not working correct. So maybe that, but again I doubt it.
3. ed1 mentions the Toggle Toolbar button. That might be possible. I did change some of its code for this release, and also it does watch the toolbar it belongs to for changes so it can update its icon. If something is causing that toolbar to have lots of attribute changes, that could cause havoc.

I will try and fix this problems and post back when I have something to test.

Have I helped you? Do you like my add-ons?
Would you consider donating to show your appreciation for my efforts?

/images/paypal.png
ReportQuote
#15
Could everyone please see how this extension works for them:
https://codefisher.org/download/toolbar_buttons/toolbar-buttons-1.0.2b1.xpi

Have I helped you? Do you like my add-ons?
Would you consider donating to show your appreciation for my efforts?

/images/paypal.png
ReportQuote
#16
when you get a moment the password manager button is no longer opening with the search field filled out like the cookie manager button does, it was working with my old copy
ReportQuote
#17
Michael, version 1.0.2b1 seems to resolve the problems that I noticed. The icon is back on the Bookmarks Toolbar button and Firefox is no longer freezing.

I now have 2 buttons for toggling the Bookmarks Toolbar - one has the red ribbon and red/green +/- badge (same as previously) - the other is the yellow 5-point bookmark star icon. Both buttons do the same thing - toggle the Bookmarks Toolbar. Did you mean to have 2 buttons with identical function?

Thank you very much for your work on maintaining this great addon.

Edited by ed1 on Nov. 19, 2014, 8:16 a.m.

ReportQuote
#18
Update on 1.0.2

I have reverted to my non-functional profile with 1.0.1. This caused FF to hang at startup, as originally reported.

I then killed FF, restarted it in Safe Mode, removed TB 1.0.1 and installed 1.0.2.

On restart, FF cranked up perfectly as it did before.

There were a number of other addons which needed update because of 33.1.1 incompatibility, but I haven't updated them.

They wouldn't seem to be part of the problem, and it seems that whatever you put into the TB 1.0.2 release is a fix for the original problem.

Excellent work, and well worth a donation.
ReportQuote
#19
Working great now. All icons present and/or accounted for. Thank you. Headed to donation link now.
ReportQuote
#20
@az
That button is not mine, I am still yet to implement it. It must be coming from another extension. If you find out where, send me the code, I will fix it and add it in.

@ed1
Good to know I got something right :) The yellow star icon is not mine, there is no yellow star icon in the extension.

@Powhyfo
Thanks :)

Have I helped you? Do you like my add-ons?
Would you consider donating to show your appreciation for my efforts?

/images/paypal.png
ReportQuote

Post new Reply